Unit 1: Network Infrastructure
This will allow you to demonstrate your networking skills, knowledge, and abilities, with a focus on enterprise-level switching, routing, and multicast components that support cross-platform (inter)operability and integration with the most recent software-defined technologies.

OSPF Route Summarization

A single route entry with a prefix and prefix length more than one or smaller component routes is created by route summarization in any Interior Gateway Protocol (IGP). Take summary route 20.1.0.0/16 as an example. It encompasses subnets 20.1.1.0/24, 20.1.4.132/30, and all the subnets between 20.1.0.0 and 20.1.255.255. Indirectly, summary routes improve convergence by reducing the size of topological databases and routing tables. It is required that all routers inside an OSPF area have:

  • There will be identical link state databases once the flooding process is over.
  • Same paths for the summary.
  • Each summary must be missing the same component subnets since they are absent.

OSPF only permits route summarization in the event that the routes are injected into a area by one of the following types of routers, which is necessary for the aforementioned thing to take place:

  • Area Border Router (ABR) –inter-area routes
  • Autonomous System Boundary Router (ASBR) -external routes

Commands for OSPF Route Summarization:

                     Type of router

              Router OSPF subcommand

                             ABR

area <area-id> range <network-id> <prefix-mask> [advertise |not-advertise]

                             ASBR

 

summary-address <network-id> <prefix-mask> [not-advertise]

 

Use either “advertise” or “not-advertise” as your keywords. It is possible to exclude the subnets that are inferred by the summary using the not-advertise keyword.

Setting up OSPF Route Summarization:

Step 1. Below is the two-router topology as shown in example below:

Step 2. Let’s configure the IPv4 address on the physical interface of the routers by following these steps:

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 20.0.0.1 255.255.255.0
R1(config-if)#no shutdown

R2(config)#interface FastEthernet0/0
R2(config-if)#ip address 20.0.0.2 255.255.255.0
R2(config-if)#no shutdown

Step 3: Set up an IPv4 address for a loopback interface on R2:

R2(config)#interface Loopback0
R2(config-if)#ip address 8.8.8.8 255.255.255.255

Step 4: Set up IPv4 addresses for loopback interfaces on R1:

R1(config)#interface Loopback0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#interface Loopback1
R1(config-if)#ip address 192.168.2.1 255.255.255.0

Step 5: Use the command router OSPF to set up the OSPF process on both routers:

R1(config)#router OSPF 1
R1(config-router)#exit

R2(config)#router OSPF 1
R2(config-router)#exit

Step 6: Using the interface level subcommand IP OSPF area to enable OSPF on the interfaces:

R1(config)#interface FastEthernet0/0
R1(config-if)#ip OSPF 1 area 1
R1(config-if)#interface Loopback0
R1(config-if)#ip OSPF 1 area 0
R1(config-if)#interface Loopback1
R1(config-if)#ip OSPF 1 area 0

R2(config)#interface FastEthernet0/0
R2(config-if)#ip OSPF 1 area 1
R2(config-if)#interface Loopback0
R2(config-if)#ip OSPF 1 area 1

Step 7: Examining the routers’ IPv4 routing tables to find the OSPF route entry

No Attachment Found
No Attachment Found