Unit 1: Network Infrastructure
This will allow you to demonstrate your networking skills, knowledge, and abilities, with a focus on enterprise-level switching, routing, and multicast components that support cross-platform (inter)operability and integration with the most recent software-defined technologies.
This feature is utilized most frequently with topologies that consist of hubs and spokes. Stubs are configured on the routers that are located at the spoke sites. This configuration ensures that the spoke sites do not serve as a transit path for the traffic.
In EIGRP Hello packets, a stub router will transmit the information that it has the stub feature activated. As a result, the stub router will not receive any queries for routes of any kind.
This is one method for resolving the well-known EIGRP network stuck-in-active problems.
To set up this feature on Router 2, let’s utilize the topology below.
EIGRP neighborship has been established between Router 1 and Router 2 in the topology described above, as seen below:
R1#sh ip eigrp neighborsEIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Cnt Seq Num
(sec) (ms)
0 90.90.12.2 Fa0/0 13 00:04:25 107 642 0 7
R2 has been configured as follows:
ip route 3.3.3.3 255.255.255.255 90.90.23.3
!
router eigrp 100
network 2.2.2.2 0.0.0.0
network 90.90.12.0 0.0.0.3
redistribute static metric 1000 1 255 1 1500
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 90.90.12.2 255.255.255.252
!
interface FastEthernet1/0
ip address 90.90.23.2 255.255.255.0
We will now examine the EIGRP routes on R1 in accordance with the configuration of the EIGRP Stub feature on R2 using the following parameters.
- Eigrp stub Connected
- Eigrp stub static
- Eigrp stub receive-only
- Eigrp stub redistributed
- CONFIGURING EIGRP STUB CONNECTED
R2(config-router)#eigrp stub connected
Verification:
2.2.2.2 is the only subnet that is advertised to R1 that is connected.In spite of the fact that 90.90.23.0/24 is also a connected network, it is not advertised since it is not advertised following the EIGRP process.
R1#sh ip route eigrp
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/156160] via 90.90.12.2, 00:00:06, FastEthernet0/0
- CONFIGURING EIGRP STUB STATIC
R2(config-router)#eigrp stub static
Verification:
R1 only sees the advertised static route to 3.3.3.3