Unit 1: Network Infrastructure
This will allow you to demonstrate your networking skills, knowledge, and abilities, with a focus on enterprise-level switching, routing, and multicast components that support cross-platform (inter)operability and integration with the most recent software-defined technologies.
The default method of neighbor discovery in EIGRP is multicast; however, the protocol also gives you the option to configure EIGRP neighbors in a static manner. EIGRP will only use unicast after you have completed this step, and it will disable EIGRP multicast on the interface that you have chosen.
In certain circumstances, especially those in which multicast is not supported, or in situations in which you want to reduce the overhead of multicast transmission, this could be advantageous.
For instance, if two connected routers have EIGRP routing enabled,
With the following command, we can add a connected network and create dynamic neighborship: –
router(config)#router eigrp <AS_number>
router(config)#network <network_IP> <wildcard_mask>
router(config)#exit
The network must first be added to the EIGRP topology in order to establish static neighborship. The static neighbor must then be configured using its IP address and the router’s exit interface.
router(config)#router eigrp <AS_number>
router(config)#network <network_IP> <wildcard_mask>
router(config)#neighbor <ip_add_neighbor> <exit_interface_id>
router(config)#exit
In other words, if the router is transmitting unicast traffic to establish a Static Neighborship, it also needs a unicast reply in return on that interface in order to effectively establish the neighborship. This neighbor command prevents sending and receiving any multicast traffic for EIGRP on that exit interface.
Let’s have a look at below topology:-
Configuring EIGRP on all Routers:
R1:
R1(config)#router eigrp 100
R1(config-router)#network 101.1.1.0 0.0.0.255
R1(config-router)#network 111.1.1.0 0.0.0.255
R1(config-router)#exit
R2:
R2(config)#router eigrp 100
R2(config-router)#network 101.1.1.0 0.0.0.255
R2(config-router)#network 121.1.1.0 0.0.0.255
R2(config-router)#exit
R3:
R3(config)#router eigrp 100
R3(config-router)#network 121.1.1.0 0.0.0.255
R3(config-router)#exit
R4:
R4(config)#router eigrp 100
R4(config-router)#network 111.1.1.0 0.0.0.255
R4(config-router)#exit
Let’s Set Up R1 and R2’s Static Neighborship
Step 1: To start, let’s just set up a static neighbor on R1 and use debugging to observe the differences.