Unit 1: Network Infrastructure
This will allow you to demonstrate your networking skills, knowledge, and abilities, with a focus on enterprise-level switching, routing, and multicast components that support cross-platform (inter)operability and integration with the most recent software-defined technologies.

EIGRP Named Mode

EIGRP Named Mode, also known as Multi-AF Mode, is a new feature added to EIGRP in Version 15.x.

Its purpose is to make setting up EIGRP easier by putting all of the configuration in one place. With the old EIGRP version, the configuration was split between the interface and the global process, which made it harder to see all of the EIGRP configuration at once.

There have been no changes to the back end, so you can still run EIGRP between two peers, one in classic mode and the other in named mode.

We will look at the basic setup, as well as authentication and setting up eigrp named mode redistribution, using the simple methodology shown below.

Let’s start by setting up simple connectivity between R1 and R2.

R1 

int e0/0
ip address 10.0.11.1 255.255.255.252

int lo0
ip add 1.1.1.1 255.255.255.255

R2 

int e0/0
ip address 10.0.11.2 255.255.255.252

int lo0
ip add 2.2.2.2 255.255.255.255

Before setting up EIGRP, make sure that R1 and R2 can talk to each other.

R1#ping 10.0.11.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.11.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 120/148/176 ms

Now that our connection is confirmed, we can go ahead and configure EIGRP Named Mode.

Named mode gives you two choices, one of which is a word, as opposed to EIGRP classic mode, when you had to type router eigrp and then choose an AS number.

Type in a word and press enter; the next step is to set up the address-family and autonomous-system numbers. There may be local significance to the EIGRP name, but

Just like in classic mode, the AS numbers must be same across all routers.

R1(config)#router eigrp NETWORKWORDS
R1(config-router)#address-family ipv4 unicast autonomous-system 100

Let’s look at the EIGRP named mode setup now.

R1#sh run | sec router eigrp
router eigrp NETWORKWORDS
!
address-family ipv4 unicast autonomous-system 100
!
topology base
exit-af-topology
exit-address-family
R1#

As of right now, there are no interfaces that have been enabled for EIGRP, which means that no neighbors are appearing. Returning to the named configuration and adding a network statement is something that has to be done.

R1(config)#router eigrp NETWORKWORDS
R1(config-router)#address-family ipv4 unicast autonomous-system 100
R1(config-router-af)#network 10.0.11.1 0.0.0.0
R1(config-router-af)#network 1.1.1.1 0.0.0.0
R1(config-router-af)#end
*Feb 19 21:57:21.375: %DUAL-5-NBRCHANGE: EIGRP-IPv4 12:
Neighbor 10.0.11.2 (FastEthernet0/0) is up: new adjacency

You should be able to see the EIGRP neighbor come up because I have previously configured R2.

To confirm that we can connect to R2’s loopback, let’s ping 2.2.2.2.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/125/156 ms

Do you want to know the difference between Named Mode and Multi-AF Mode? The short answer is that there is none. These two things are the same.

Redistributing EIGRP-Named Modes

At this point, let us have a look at something that, at first glance, appears to be relatively straightforward; however, with the implementation of eigrp named mode, the process of redistribution has become somewhat more complicated.

In the beginning, let’s broaden our topology to include an additional router that is operating OSPF.

In OSPF, R3 has its loopback set at 3.3.3.3, and we are going to re-distribute OSPF into EIGRP on R2.

The first question that has to be answered is where exactly in the new EIGRP setup the redistribution is carried out. What is the answer?

The address family can be specified by entering the eigrp named mode, and it will be located under the topology basis.

R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router eigrp NETWORKWORDS
R2(config-router)#address-family ipv4 unicast autonomous-system 100

R2(config-router-af)#topology base
R2(config-router-af-topology)#redistribute ospf 1 metric 1 1 1 1 1

You must give a metric while redistributing into EIGRP.

Membership Required

This Course and partial content under every lesson is restricted for Members Only. You must be a member to fully access this Course / Lesson content. You can still preview partially visible text content by using "Preview" tab for Every Lesson.

View Membership Levels

Already a member? Log in here

No Attachment Found
No Attachment Found