Leak-maps are an EIGRP method that can be used for two things:
- Through the use of summarisation, it is possible to advertise more precise routes.
- So a stub-router can offer routes that go beyond it.
The leak-map doesn’t seem to help with summarization; why would we want to undo the results of summarization? We thought that one of the goals of summarization was to keep the source network secret from the routers that get the summary?
As long as you bear in mind that the real aim of summarization is to lower the query-scope and update size, you would be correct in thinking that. Nevertheless, the leak-map does not negate that; rather, it enables you to keep the benefit of summarization (smaller routing table) and enables more-specific routing at a more granular level. This is what it accomplishes.
This is helpful for a variety of things, including traffic engineering. Think about the following configuration of the network:
After taking a look at our diagram, it is clearly apparent that the Router2 is connected to a network that is directly connected (192.168.100.0/24). To ensure that the routing is as efficient as possible, we need to make certain that Router1 is always traveling directly to that subnet, rather than going through Router3. Within the context of this approach, the leak-map is essential because it guarantees that we will not transit Router3 first. In the event that we relied heavily on Router3 to connect to our networks and the interconnect between Router3 and Router2 became unavailable, we would be forced to adopt routes that were less than optimum in order to connect to the 192.168.100.0/24 network!
Configuration (Summary Leak Map)
Summary Leak Maps are easy to configure:
- Set up a prefix-list that includes the routes you want to leak.
- Give that route-map the prefix-list.
- Use the leak-map keyword to connect your route-map to your summarization statement.
We will begin with Router3 because his summary is quite simple to understand.
router eigrp 555
network 0.0.0.0
!
int e0/0
!our interface that points to Router1
ip address 10.0.1.2 255.255.255.0
no shut
ip summary-address eigrp 555 0.0.0.0/0
We copy that same config to Router2:
router eigrp 555
network 0.0.0.0
!
int e0/0
!our interface that points to Router1
ip address 10.0.1.3 255.255.255.0
no shut
ip summary-address eigrp 555 0.0.0.0/0
Router1 has a default route in this configuration, but the failure situation that was talked about could still be a problem. We use our leak-map to fix this.
Router2(config)# ip prefix-list connected-network seq 10 permit 192.168.100.0/24
Router2(config)#route-map leak-into-eigrp
Router2(config-route-map)#match ip address prefix-list connected-network
Router2(config)#exit
Router2(config)#int e0/0
Router2(config-if)#ip summary-address eigrp 555 0.0.0.0/0 leak-map leak-into-eigrp
At this point, Router1 will be in possession of the summary routes, in addition to the leaked prefix 192.168.100.0/24!
At this point, our Hub routers – Router2 & Router3, will black-hole routing for all traffic for which they do not have an explicit route; you will need to alter the administrative distance of your summary routes.
Stub Leak-Maps
Taking into consideration the role that stub-router advertising plays: Through this action, you are communicating to other routers that you are not the transit-router for any other networks besides the ones that you are presently advertising through your network. What if you wanted to restrict the query domain for the routes that you have connected, but you are also the transit router for other routes? What would you do?
It was feasible to make the branch edge-router a stub while enabling it to serve as a transit router for devices downstream by utilizing stub leakage.
Think about the network that is as follows:
Here we have Router1 set up as a stub-router; he can’t share summary routes or non-connected networks, and he shouldn’t be queried for active routes, so on and so forth. As a consequence of this, Router3, Router2, and the rest of the network are not being informed about Router4’s 172.16.18.0/24 network.
In the event that Router3 loses upstream connectivity and the link to Router2, Router1 would transform into a transit router for all of Router3’s traffic because we are unable to remove the stub configuration from Router1.
The stub leak-map is useful in this situation.
Configuration (Stub Leak Map)
- Set up a prefix-list that includes the routes you want to leak.
- Put the prefix-list on a route-map.
- Using the syntax eigrp stub leak-map {route-map}, assign your route-map to the EIGRP process.
- You might want to add the “connected” keyword for your own sanity.
In conjunction with the network described above (example), we are going to leak the subnet 172.16.18.0/24 from Router4. In the beginning, we are going to look at the routing table on Router1 without our stub configuration.