When you configure an interface in an OSPF domain as a passive interface, OSPF stops sending Hellos on that interface. OSPF will keep advertising the subnet’s passive interface as a stub network. If there isn’t an OSPF router connected to an interface, it should only be set up as a passive interface. This way, end hosts or routers that aren’t connected to OSPF won’t get any OSPF information. By reducing the number of interfaces it has to talk to, the OSPF passive interface makes the routing work easier on the CPU for the OSPF protocol. The passive interface still listens for OSPF hello packets, but it doesn’t send them out or originate them.
Configuring the Passive Interface of OSPF:
Router OSPF subcommand |
Description |
Examples |
passive-interface default |
configure all interfaces to be passive interfaces, leaving a single or a couple |
Router(config)#router ospf <process-id> |
passive-interface <interface interface-id> |
Configure the passive-interface on a single or a couple of interfaces individually |
Router(config)#router ospf <process-id> |
The OSPF Passive Interface Configuration:
Step 1: Creating two different router topologies in GNS3 is the first step, as explained in the figure below:
Step 2: configure the IPv4 address on the physical interface of the routers by following these steps:
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.0.12.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface FastEthernet0/1
R1(config-if)#ip address 192.168.27.130 255.255.255.0
R1(config-if)#no shutdown
R2(config)#interface FastEthernet0/0
R2(config-if)#ip address 10.0.12.1 255.255.255.0
R2(config-if)#no shutdown
Step 3: you will configure an IPv4 address for a loopback interface on resource R2.
R2(config)#interface Loopback0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
Step 4: To configure the default gateway and IPv4 address on the PC:
PC> ip 192.168.27.131/24 192.168.27.130
Checking for duplicate address...
PC : 192.168.27.131 255.255.255.0 gateway 192.168.27.130
Step 5: the OSPF process is configured on both routers using the command configuration command router OSPF <process-id> :
R1(config)#router ospf 1
R1(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#exit
Step 6: Using the interface level to enable OSPF on the interfaces subcommand ip ospf <process-id> area <area-id> :