Before exchanging LSAs and creating the SPF tree, routers in an OSPF routing domain should establish full connections. In order for two routers to become neighbors, they must fulfill certain conditions, one of which is that the Hello packets they exchange must include the same OSPF Hello and Dead interval values.
OSPF makes use of numerous timers, one of which is the Hello timer. Every Hello Interval seconds, the router is instructed to deliver a Hello packet across a specific interface by the Hello timer, an interval timer.
The Hello Interval, given in seconds, is the period that elapses between two successive Hello packets transmitted over the interface and is announced in OSPF Hello messages. It is possible that different router interfaces use different OSPF Hello intervals.
Also, Router Dead Interval, also known as “Dead interval” in OSPF, is stated in OSPF. Hello packets are sent out an interface. This number tells you how long the router will wait in seconds for a neighbor to send a Hello packet before it shuts down. Router Dead Interval seconds pass before the router marks a neighbor as dead if it doesn’t get any Hello packets from that neighbor.
The network topology below can be used for this task:-
Hello and Dead Interval Values for OSPF by Default
Different types of OSPF networks have different default values for the Hello and Dead intervals. Here is a table that contains all the different types of OSPF networks, along with the Hello and Dead interval settings for each.
OSPF Network Type |
Default Hello Interval |
Default Dead Interval |
Point-to-point |
10 |
40 |
Point-to-multipoint |
30 |
120 |
Point-to-multipoint non-broadcast |
30 |
120 |
Broadcast |
10 |
40 |
Non-broadcast |
30 |
120 |
Keep in mind that the default Dead interval is four times the usual Hello interval.
To show what the table data means, here’s how we configure our OSPF routing domain:
Router
|
Interface |
IP Address |
OSPF Network Type |
R1 |
GigabitEthernet 0/2 |
20.0.12.1/24
|
Point-to-point |
R1 |
GigabitEthernet 0/4
|
20.0.14.1/24 |
Point-to-multipoint |
R2 |
GigabitEthernet 0/1 |
20.0.12.2/24 |
Point-to-point |
R2 |
GigabitEthernet 0/3 |
20.0.23.2/24 |
Point-to-multipoint non-broadcast |
R2 |
GigabitEthernet 0/4 |
20.0.24.2/24
|
Broadcast |
R3 |
GigabitEthernet 0/2 |
20.0.23.3/24
|
Point-to-multipoint non-broadcast |
R3 |
GigabitEthernet 0/4 |
20.0.34.3/24 |
Non-broadcast |
R4 |
GigabitEthernet 0/1 |
20.0.14.4/24
|
Point-to-multipoint |
R4 |
GigabitEthernet 0/2
|
20.0.24.4/24
|
Broadcast |
R4 |
GigabitEthernet 0/3
|
20.0.34.4/24 |
Non-broadcast |
The routers have the following configurations applied to them:
Router R1
Router(config)# hostname R1
R1(config)#
R1(config)# interface GigabitEthernet0/2
R1(config-if)# ip address 20.0.12.1 255.255.255.0
R1(config-if)# ip ospf network point-to-point
R1(config-if)# no shutdown
R1(config-if)#
R1(config-if)# interface GigabitEthernet0/4
R1(config-if)# ip address 20.0.14.1 255.255.255.0
R1(config-if)# ip ospf network point-to-multipoint
R1(config-if)# no shutdown
R1(config-if)#
R1(config-if)# router ospf 1
R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 20.0.12.1 0.0.0.0 area 0
R1(config-router)# network 20.0.14.1 0.0.0.0 area 0
Router R2
Router(config)# hostname R2
R2(config)#
R2(config)# interface GigabitEthernet0/1
R2(config-if)# ip address 20.0.12.2 255.255.255.0
R2(config-if)# ip ospf network point-to-point
R2(config-if)# no shutdown
R2(config-if)#
R2(config-if)# interface GigabitEthernet0/3
R2(config-if)# ip address 20.0.23.2 255.255.255.0
R2(config-if)# ip ospf network point-to-multipoint non-broadcast
R2(config-if)# no shutdown
R2(config-if)#
R2(config-if)# interface GigabitEthernet0/4
R2(config-if)# ip address 20.0.24.2 255.255.255.0
R2(config-if)# ip ospf network broadcast
R2(config-if)# no shutdown
R2(config-if)#
R2(config-if)# router ospf 1
R2(config-router)# router-id 2.2.2.2
R2(config-router)# neighbor 20.0.23.3
R2(config-router)# network 20.0.12.2 0.0.0.0 area 0
R2(config-router)# network 20.0.23.2 0.0.0.0 area 0
R2(config-router)# network 20.0.24.2 0.0.0.0 area 0
Router R3
Router(config)# hostname R3
R3(config)#
R3(config)# interface GigabitEthernet0/2
R3(config-if)# ip address 20.0.23.3 255.255.255.0
R3(config-if)# ip ospf network point-to-multipoint non-broadcast
R3(config-if)# no shutdown
R3(config-if)#
R3(config-if)# interface GigabitEthernet0/4
R3(config-if)# ip address 20.0.34.3 255.255.255.0
R3(config-if)# ip ospf network non-broadcast
R3(config-if)# no shutdown
R3(config-if)#
R3(config-if)# router ospf 1
R3(config-router)# router-id 3.3.3.3
R3(config-router)# neighbor 10.0.23.2
R3(config-router)# neighbor 10.0.34.4
R3(config-router)# network 20.0.23.3 0.0.0.0 area 0
R3(config-router)# network 20.0.34.3 0.0.0.0 area 0
Router R4
Router(config)# hostname R4
R4(config)#
R4(config)# interface GigabitEthernet0/1
R4(config-if)# ip address 20.0.14.4 255.255.255.0
R4(config-if)# ip ospf network point-to-multipoint
R4(config-if)# no shutdown
R4(config-if)#
R4(config-if)# interface GigabitEthernet0/2
R4(config-if)# ip address 20.0.24.4 255.255.255.0
R4(config-if)# ip ospf network broadcast
R4(config-if)# no shutdown
R4(config-if)#
R4(config-if)# interface GigabitEthernet0/3
R4(config-if)# ip address 20.0.34.4 255.255.255.0
R4(config-if)# ip ospf network non-broadcast
R4(config-if)# no shutdown
R4(config-if)#
R4(config-if)# router ospf 1
R4(config-router)# router-id 4.4.4.4
R4(config-router)# neighbor 20.0.34.3
R4(config-router)# network 20.0.14.4 0.0.0.0 area 0
R4(config-router)# network 20.0.24.4 0.0.0.0 area 0
R4(config-router)# network 20.0.34.4 0.0.0.0 area 0
All types of OSPF networks use the same Hello and Dead interval numbers, which can be seen in Examples 1, 2, 3, 4, and 5.
R1# show ip ospf interface gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
Internet Address 20.0.12.1/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
omitted output
OSPF timers for a point-to-point interface that supports OSPF
R1# show ip ospf interface gigabitEthernet 0/4
GigabitEthernet0/4 is up, line protocol is up
Internet Address 20.0.14.1/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
omitted output
Using OSPF timers for a point-to-multipoint interface that is enabled with OSPF
R2# show ip ospf interface gigabitEthernet 0/3
GigabitEthernet0/3 is up, line protocol is up
Internet Address 20.0.23.2/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
omitted output
R2# show running-config interface gigabitEthernet 0/3
Building configuration...
Current configuration : 165 bytes
!
interface GigabitEthernet0/3
ip address 20.0.23.2 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
duplex auto
speed auto
media-type rj45
end
Non-broadcast point-to-multipoint OSPF-enabled interface with OSPF timers
R2# show ip ospf interface gigabitEthernet 0/4
GigabitEthernet0/4 is up, line protocol is up
Internet Address 20.0.24.2/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 20.0.24.2
Backup Designated router (ID) 4.4.4.4, Interface address 20.0.24.4
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
omitted output
Timers for OSPF on a broadcast link that supports OSPF
R3# show ip ospf interface gigabitEthernet 0/4
GigabitEthernet0/4 is up, line protocol is up
Internet Address 20.0.34.3/24, Area 0, Attached via Network Statement
Process ID 1, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 1
Topology-MTID Cost Disabled Shutdown Topology Name
0 1 no no Base
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 4.4.4.4, Interface address 10.0.34.4
Backup Designated router (ID) 3.3.3.3, Interface address 20.0.34.3
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
omitted output
OSPF timers for a interfaces that is configured for OSPF non-broadcast
Why Should the Hello and Dead Intervals Be Adjusted?
When the Hello interval is high, it takes a long time for OSPF adjacencies to form. This means that dropping the Hello timer’s interval speeds up the process of connecting all OSPF neighbors. That would, however, lead to more OSPF routing traffic.