Unit 1: Network Infrastructure
This will allow you to demonstrate your networking skills, knowledge, and abilities, with a focus on enterprise-level switching, routing, and multicast components that support cross-platform (inter)operability and integration with the most recent software-defined technologies.

Layer 3 EtherChannel

In this topic, we are going to cover EtherChannel on Layer 3 switches as well as the configuration process for it.

For example, while we are creating a routing protocol and forming redundancy between the Core and Distribution Layers, we would want to configure EtherChannel on Layer 3 switches. This is one of the use cases that would justify this configuration. We are now able to have a single next-hop IP address of the neighboring switch for each IP route that we have learned, which eliminates the need to learn two IP routes with the same neighboring switch but two separate next hops.

When you want to avoid using Spanning Tree Protocol (STP), you can instead use Layer 3 links to connect your Core Layer and Distribution Layer. This is another use case. Through the utilization of routing protocols, we are able to achieve greater control over load balancing and failover, and these protocols can be significantly quicker than STP.

When two Layer 3 switches are next to each other, their port-channel interface numbers can be different. However, all of the physical interfaces on a Layer 3 switch must use the same Channel Group Number. Also to turn the physical interface into a routed port or interface (Group state = from Layer 2 to Layer 3), we need to issue the command “no switchport” at the interface/port level.

Layer 3 EtherChannel Configuration

The following topology will serve as an example for the Layer 3 Etherchannel configuration. Switch1 and Switch2 are both Layer 3 switches, and we’ll set up a layer 3 etherchannel between them:-

SwitchA Configuration:

SwitchA(config)#interface range FastEthernet 0/1 - 2
SwitchA(config-if-range)#no switchport
SwitchA(config-if-range)#channel-group 1 mode desirable
SwitchA(config-if-range)#interface port-channel 1
SwitchA(config-if)#no switchport
SwitchA(config-if)#ip address 10.10.1.1 255.255.255.0

SwitchB Configuration:

SwitchB(config)#interface range FastEthernet 0/1 - 2
SwitchB(config-if-range)#no switchport
SwitchB(config-if-range)#channel-group 2 mode desirable
SwitchB(config-if-range)#interface port-channel 2
SwitchB(config-if)#no switchport
SwitchB(config-if)#ip address 10.10.1.2 255.255.255.0

Verification of the Layer 3 EtherChannel

The following instructions will show us whether our layer 3 EtherChannel configuration is functioning properly:

Membership Required

This Course and partial content under every lesson is restricted for Members Only. You must be a member to fully access this Course / Lesson content. You can still preview partially visible text content by using "Preview" tab for Every Lesson.

View Membership Levels

Already a member? Log in here

No Attachment Found
No Attachment Found